FAQ Technique > Problèmes techniques divers

[résolu] Installation de amdgpu-pro sur LM20.1 (Radeon RX 580)

(1/3) > >>

[AF>Libristes] alain65:
Bonjour à tous.

Je suis dans la m..ouise.

La nuit dernière j'ai installé LM20.1 sur mon PC principal:

--- Code: ---alain@alain-desktop:~$ inxi -CG
CPU:
  Topology: 8-Core model: AMD FX-8350 bits: 64 type: MCP L2 cache: 2048 KiB
  Speed: 1411 MHz min/max: 1400/4000 MHz Core speeds (MHz): 1: 1691 2: 1708
  3: 4164 4: 4147 5: 1585 6: 2023 7: 1861 8: 1995
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
  driver: amdgpu v: kernel
  Display: x11 server: X.Org 1.20.9 driver: amdgpu,ati
  unloaded: fbdev,modesetting,radeon,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: Radeon RX 580 Series v: 4.6.14736 Core Profile Context
alain@alain-desktop:~$
--- Fin du code ---
Qui était sous LM19.3, histoire de bénéficier d'un certain outil anisé  :siflotte:
Mal m'en a pris car, je n'arrive pas à installer amdgpu-pro  :cpopossib:
J'ai pourtant bien respecté les consignes d'installations qui avaient fonctionnées avec LM19.3: https://forums.linuxmint.com/viewtopic.php?p=1515630&sid=b2b0c1cdfdb5ad3e22e0c21b084a4876#p1515630 . Je me suis renseigné ce post est toujours valable pour LM20.1 et correspond aux consignes d'installations.
J'ai bien modifié mon: "/etc/os-release file" , pour faire croire à l'installateur que c'est une ubuntu 20.04.
Je n'ai pas mis le  "-y" au lancement du script d'installation (il parait que LM, n'aime pas répondre "oui" à notre place)
Malgré tout invariablement l'installation se termine par :

--- Code: ---Des erreurs ont été rencontrées pendant l'exécution :
 amdgpu-dkms
 amdgpu
 amdgpu-pro
 amdgpu-pro-lib32
E: Sub-process /usr/bin/dpkg returned an error code (1)

--- Fin du code ---
J'ai bien tenté des:

--- Code: ---sudo dpkg --configure -a
--- Fin du code ---
et:

--- Code: ---sudo apt-get install -f
--- Fin du code ---
Mais rien n'y fait  :(
Je me permet de mettre ici, l'intégralité de l'installation, c'est long je sais, mais si ça peut vous permettre de voir ou il y a le problème.

http://paste.alacon.org/47068

Je suis vraiment embêté car c'est ma plus grosse machine et l'installation de LM20.1 était justement en prévision du RAID. Si je n'arrive pas à démarrer cette carte graphique, je vais devoir malheureusement déclarer forfait  :cry:

Par avance merci :)  :kookoo:
 

Maeda:
Ces lignes me gêne :

--- Code: ---Le paquet amdgpu-dkms n'est pas encore configuré.
--- Fin du code ---
Vu sur ce lien, tu peux essayer d'utiliser le noyau précédent comme suggéré ?

Peut-être une piste...

[AF>Libristes] alain65:
salut Maeda  :hello:

Merci pour ta réponse, oui essayer le noyau précédent, je n' y avais pas penser  :spamafote:
Je fais ça dans la nuit et te dis quoi.
J'ai le 5.4.0-65 je vais essayer le 5.4.0-54 comme le gars de ton lien pour qui ça a fonctionné.

[AF>Libristes] alain65:

--- Citation de: Maeda le 16 février 2021 à 21:24 ---Peut-être une piste...

--- Fin de citation ---

Et une bonne ! :)
Car effectivement j'ai installé le 5.4.0-54 et ça fonctionne du premier coup  :gloiraseti:
 :banana:

Merci beaucoup Maeda, d'avoir penser au noyau, ça ne m'est pas venu à l’esprit.  :jap: :plusun:

Maeda:
 :hello:
Parfait ! Tu es prêt pour le RAID :gniak:

Navigation

[0] Index des messages

[#] Page suivante

Utiliser la version classique