Auteur Sujet: BM ne télécharge pas taches GPU pour certains projets [RESOLU]  (Lu 237 fois)

0 Membres et 1 Invité sur ce sujet

[AF>Amis des Lapins] Jean-Luc

  • Messages: 1663
  • Boinc'eur devant l'éternel
  • *****
  •   
Bonjour à tous,

Mon épouse s'est procurée une nouvelle machine sur Windows 10 et elle veut contribuer à BOINC.
Elle a une GPU NVidia 1060.

Et je rencontre un problème que je ne sais pas résoudre, un truc qui ne m'est jamais arrivé.

J'ai ajouté 4 nouveaux projets où j'ai coché pour qu'ils ne m'envoient que des WUs pour GPU (je réserve les threads CPU à WCG) :
GPUGrid, Collatz, Amicable, Einstein.

Au tout début, NO SOUCI, on m'envoie des WUs pour Collatz et pour GPUGrid et ça calcule les tâches des deux projets.

Puis tout à coup, dans la colonne "Etat" du BM, à côté des WUs Collatz, il y avait marqué un truc du genre "Pas de processeur graphique".
Et même quand toutes les WUs GPUGrid étaient terminées, il ne calculait pas les Collatz, comme s'il ne reconnaissait plus la GPU pour faire ces calculs.
J'ai alors tenté d'installer Einstein, Amicable : il ne télécharge aucune tâche GPU.
Je supprime mes WUs Collatz et il n'en a plus jamais téléchargées (il télécharge des WUs cpu mais pas GPU pour ces 3 projets).
Par contre pour GPUGrid, il télécharge et ensuite calcule très bien les taches GPU.

J'ai tout essayé :
- J'ai supprime GPUGrid de la machine pour voir si enfin il allait télécharger des WUs pour les autres projets : ECHEC !
- J'ai supprimé puis réinstallé tous les projets : ECHEC
- J'ai désinstallé BOINC complètement de la machine et réinstallé tous les 4 projets : ECHEC
- J'ai augmenté la demande en mettant "envoyer du travail pour 5 jours" : ECHEC
- .....

Il n'y a plus que GPUGrid qui m'envoie des WUs GPU pour cette machine.
Pourtant au début, Collatz marchait !

Qu'ai-je fait et comment puis-revenir en arrière ?
Si quelqu'un a une idée, je suis preneur...
« Modifié: 06 mai 2017 à 17:56 par [AF>Amis des Lapins] Jean-Luc »


Rédacteur d'un article sur BOINC, adresse :
http://www.astrocaw.eu/?p=605
Créateur d'un site actif de recherche sur les suites aliquotes :
http://www.aliquotes.com/

fzs600

  • Animateur fanatique
  • Messages: 5360
  • Boinc'eur devant l'éternel
  • *****
  •   
J'ai le même souci avec Collatz et Amicale et moi non plus je ne sais pas comment résoudre ce problème.  :??: :??: :/ :/

Utilisateur GNU-LINUX. fzs600@jappix.com

nabz

  • Animateur fanatique
  • Messages: 4438
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : BM ne télécharge pas taches GPU pour certains projets
« Réponse #2 le: 06 mai 2017 à 16:16 »
Réinstalle un pilote graphique de chez nVidia pour commencer, par exemple le 378.92.

Puis vérifie dans le journal de démarrage de Boinc que les capacités OpenCL sont bien reconnues.
Contrôle de BOINC : SAM - BoincTasks 1.73 - TThrottle 7.52 - TeamViewer 12.0
Calculs : Boinc 7.6.33 SF - VirtualBox 5.1.22 - Pilote Ati 17.3 - Pilote nVidia 385.28
OS et utilitaires : Win 7/10 x86/64 - Core Temp 1.10 - CCleaner 5.33 - DriverSweeper 3.1

[AF>Amis des Lapins] Jean-Luc

  • Messages: 1663
  • Boinc'eur devant l'éternel
  • *****
  •   
Réinstalle un pilote graphique de chez nVidia pour commencer, par exemple le 378.92.

WAOUH !!!!

Alors là, bien vu...

Avec ce pilote-là, ça marche !

Merci beaucoup nabz, cela faisait une semaine que je butais sur ce problème.
Rien à faire.
Je crois bien que je n'aurais jamais pensé à faire ça !


Rédacteur d'un article sur BOINC, adresse :
http://www.astrocaw.eu/?p=605
Créateur d'un site actif de recherche sur les suites aliquotes :
http://www.aliquotes.com/

JeromeC

  • CàA
  • Messages: 19631
  • Boinc'eur devant l'éternel
  • *****
  •   
Ah quel grand bonheur le calcul GPU, y'a encore une bonne marge de progrès avant que ça devienne vraiment grand public :)
Parce que c'était lui, parce que c'était moi.