Auteur Sujet: Question GPU sur Milkyway :)  (Lu 2307 fois)

0 Membres et 1 Invité sur ce sujet

tharkie

  • Messages: 41
  • P'tit Nouveau
  • *
Question GPU sur Milkyway :)
« le: 07 novembre 2014 à 20:35 »
Bonjour, bonsoir,

:)

J'ai un petit problème avec mon PC sur milqui :o

Voici ce que me dit BOINC :

07/11/2014 20:26:54 | Milkyway@Home | Message du serveur: ATI GPU R600 (R38xx) does not support OpenCL
07/11/2014 20:26:54 | Milkyway@Home | Tasks for NVIDIA GPU are available, but your preferences are set to not accept them
07/11/2014 20:26:54 | Milkyway@Home | This computer has reached a limit on tasks in progress

Or... J'ai une R9 290 & un 3930k sous W8.1 PRO...

On dirait que milqui ne reconnait pas ma CG :'(

Une idée, des conseils ?

Merci

Cordialement

RLDF

  • Messages: 4483
  • Boinc'eur devant l'éternel
  • *****
  •   
    • avatar ?
Re : Question GPU sur Milkyway :)
« Réponse #1 le: 07 novembre 2014 à 22:54 »
peux-tu coller le début du journal des evenement quand boinc se lance, il doit détecter ou pas ta R9

vérifie aussi sur ton compte milkyway si tu as coché GPU nvidia dans les préférences de milkyway

Prof

  • Messages: 1867
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : Question GPU sur Milkyway :)
« Réponse #2 le: 07 novembre 2014 à 23:25 »
il me dit pareil avec ma R9 280X!!
Pour l'équipe:PMac bi-G4 1,83GHz 1,25Go de RAM 1 MacPro octo X5570 2.93GHz 16 24Go de RAM et 1 MacPro dodéca X5650 2.66GHz 20 32Go de RAM
Un petit proverbe qui va bien avec l'air du temps:Quand le dernier arbre sera abattu, La dernière rivière empoisonnée, Le dernier poisson pêché, Alors vous découvrirez Que l'argent ne se mange pas. A méditer...;-)

Philippe06121966

  • Invité
Re : Question GPU sur Milkyway :)
« Réponse #3 le: 08 novembre 2014 à 07:27 »
 :hello:

Nous avons parlé de ce problème + SPICA a donné des solutions dans le topic MilkyWay

relis ce topic STP, je l'ai déjà expliqué deux fois, il faut revenir peut-etre sur 4-5 pages mais cela y ait et j'ai pas le temps de rechercher. Bon, je crois que je vais le mettre dans le premier post le 'mode d'emploi' quand j'aurais le temps de le retrouver...

 :hello:

Ne cherche pas, tout est là + le lien vers ton post original :

http://forum.boinc-af.org/index.php/topic,2287.msg385455.html#msg385455

 :kookoo:

 :hello:


tharkie

  • Messages: 41
  • P'tit Nouveau
  • *
Re : Question GPU sur Milkyway :)
« Réponse #4 le: 08 novembre 2014 à 16:20 »
Bon et bien génial !

Merci beaucoup, je m'en vais tester ça !!!

Je me doutais bien qu'il y avait une broutille comme cela qu'il fallait trafiquer :)

Merci encore ;)

Attention, j'ai modifié le texte ainsi que le app_info.xml et les fichiers à télécharger, il existe des versions plus récentes !
:hello: tout le monde,
les possesseurs de R9 290 se posent certainement la même question que moi.
Comment faire marcher Milkyway GPU sur ces  :priz2tet: :cavachier: :rhaa:   :electric: cartes R9 290  :cavachier: :cavachier:

Après lecture du forum Milky, j'ai fini par trouver la solution que voici...
Pour info, je l'ai fait avec BOINC 7.2.42 sous Windows 8.1 Pro 64 bits... donc si vous avez un autre OS, il faut modifier des choses...

Donc pour Windows 8.1 PRO, il faut faire ceci :

créer un app_info.xml dans le répertoire du projet milky (ce fichier ne permet de faire QUE du GPU Milky):
<app_info>
<app>
<name>milkyway</name>
</app>
<file_info>
<name>milkyway_separation_1.20_windows_x86_64__opencl_amd_ati.exe</name>
<executable/>
</file_info>
<app_version>
<app_name>milkyway</app_name>
<version_num>120</version_num>
<platform>windows_x86_64</platform>
<flops>1.0e11</flops>
<avg_ncpus>1</avg_ncpus>
<max_ncpus>1</max_ncpus>
<coproc>
<type>ATI</type>
<count>0.333</count>
</coproc>
<cmdline>--gpu-disable-checkpointing</cmdline>
<file_ref>
<file_name>milkyway_separation_1.20_windows_x86_64__opencl_amd_ati.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app>
<name>milkyway_separation__modified_fit</name>
</app>
<file_info>
<name>milkyway_separation__modified_fit_1.36_windows_x86_64__opencl_ati_101.exe</name>
<executable/>
</file_info>
<app_version>
<app_name>milkyway_separation__modified_fit</app_name>
<version_num>130</version_num>
<platform>windows_x86_64</platform>
<api_version>7.2.42</api_version>
<flops>1.0e11</flops>
<avg_ncpus>1</avg_ncpus>
<max_ncpus>1</max_ncpus>
<coproc>
<type>ATI</type>
<count>1</count>
</coproc>
<cmdline></cmdline>
<file_ref>
<file_name>milkyway_separation__modified_fit_1.36_windows_x86_64__opencl_ati_101.exe</file_name>
<main_program/>
</file_ref>
</app_version>
</app_info>

ensuite, il faut charger différents fichiers qui se trouvent sur cette page :ICI

Plus exactement : télécharger les fichiers suivants et mettez les dans le même répertoire que l'app_info :
http://milkyway.cs.rpi.edu/milkyway/download/milkyway_separation__modified_fit_1.36_windows_x86_64__opencl_ati_101.exe
http://milkyway.cs.rpi.edu/milkyway/download/milkyway_separation_1.20_windows_x86_64__opencl_amd_ati.exe

Bon courage...
Si vous voulez optimiser faire plusieurs UTs à la fois, vous pouvez changer les valeurs
<avg_ncpus>1</avg_ncpus> en <avg_ncpus>0.5</avg_ncpus>  ou <avg_ncpus>0.25</avg_ncpus> ou....pour utilsier moins de CPU et
<count>1</count> en <count>0.5</count>(2 UTs à la fois) voire <count>0.33</count> (3 UTs à la fois) ou <count>0.25</count>( 4 UTs à la fois)...

perso avec 0.5 et 0.5 c'est pas mal, je regarde ce qui est le mieux en ce moment...

Ces paramètres que tu donnais, c'était pour la 290.
Tu crois que ce sont les mêmes pour la 290X ?

Jean-Luc



Bon sinon, voici mon journal de démarrage :

Citer
08/11/2014 16:13:30 |  | cc_config.xml not found - using defaults
08/11/2014 16:13:30 |  | Starting BOINC client version 7.2.42 for windows_x86_64
08/11/2014 16:13:30 |  | log flags: file_xfer, sched_ops, task
08/11/2014 16:13:30 |  | Libraries: libcurl/7.25.0 OpenSSL/1.0.1 zlib/1.2.6
08/11/2014 16:13:30 |  | Data directory: C:\ProgramData\BOINC
08/11/2014 16:13:30 |  | Running under account *******
08/11/2014 16:13:30 |  | OpenCL: AMD/ATI GPU 0: Hawaii (driver version 1598.5 (VM), device version OpenCL 2.0 AMD-APP (1598.5), 4096MB, 4096MB available, 3200 GFLOPS peak)
08/11/2014 16:13:30 |  | OpenCL CPU: Intel(R) Core(TM) i7-3930K CPU @ 4.40GHz (OpenCL driver vendor: Advanced Micro Devices, Inc., driver version 1598.5 (sse2,avx), device version OpenCL 1.2 AMD-APP (1598.5))
08/11/2014 16:13:30 | SETI@home | Found app_info.xml; using anonymous platform
08/11/2014 16:13:30 |  | App version needs CAL but GPU doesn't support it
08/11/2014 16:13:30 |  | App version needs CAL but GPU doesn't support it
08/11/2014 16:13:30 |  | App version needs CAL but GPU doesn't support it
08/11/2014 16:13:30 |  | App version needs CAL but GPU doesn't support it
08/11/2014 16:13:30 |  | Host name: 3930k
08/11/2014 16:13:30 |  | Processor: 12 GenuineIntel        Intel(R) Core(TM) i7-3930K CPU @ 4.40GHz [Family 6 Model 45 Stepping 7]
08/11/2014 16:13:30 |  | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss htt tm pni ssse3 cx16 sse4_1 sse4_2 popcnt aes syscall nx lm vmx tm2 dca pbe
08/11/2014 16:13:30 |  | OS: Microsoft Windows 8.1: Professional x64 Edition, (06.03.9600.00)
08/11/2014 16:13:30 |  | Memory: 15.94 GB physical, 19.85 GB virtual
08/11/2014 16:13:30 |  | Disk: 237.96 GB total, 179.25 GB free
08/11/2014 16:13:30 |  | Local time is UTC +1 hours
08/11/2014 16:13:30 | Milkyway@Home | URL http://milkyway.cs.rpi.edu/milkyway/; Computer ID 59****; resource share 100
08/11/2014 16:13:30 | SETI@home | URL http://setiathome.berkeley.edu/; Computer ID 73*****; resource share 1000
08/11/2014 16:13:30 | SETI@home Beta Test | URL http://setiweb.ssl.berkeley.edu/beta/; Computer ID 7****; resource share 100
08/11/2014 16:13:30 | PrimeGrid | URL http://www.primegrid.com/; Computer ID 43****; resource share 100
08/11/2014 16:13:30 | SETI@home | General prefs: from SETI@home (last modified 13-Jul-2014 16:33:07)
08/11/2014 16:13:30 | SETI@home | Computer location: home
08/11/2014 16:13:30 | SETI@home | General prefs: no separate prefs for home; using your defaults
08/11/2014 16:13:30 |  | Reading preferences override file
08/11/2014 16:13:30 |  | Preferences:
08/11/2014 16:13:30 |  | max memory usage when active: 4897.69MB
08/11/2014 16:13:30 |  | max memory usage when idle: 14693.07MB
08/11/2014 16:13:30 |  | max disk usage: 20.00GB
08/11/2014 16:13:30 |  | max CPUs used: 11
08/11/2014 16:13:30 |  | (to change preferences, visit a project web site or select Preferences in the Manager)
08/11/2014 16:13:30 | PrimeGrid | Task pps_sr2sieve_77838941_0 is 0.49 days overdue; you may not get credit for it.  Consider aborting it.
08/11/2014 16:13:30 |  | Not using a proxy
08/11/2014 16:13:31 |  | Suspending computation - user request
08/11/2014 16:14:31 | SETI@home | Sending scheduler request: To fetch work.
08/11/2014 16:14:31 | SETI@home | Requesting new tasks for CPU and ATI
08/11/2014 16:14:37 | SETI@home | Scheduler request completed: got 0 new tasks
08/11/2014 16:14:37 | SETI@home | Not sending work - last request too recent: 247 sec

« Modifié: 08 novembre 2014 à 17:10 par tharkie »

Philippe06121966

  • Invité
Re : Question GPU sur Milkyway :)
« Réponse #5 le: 08 novembre 2014 à 16:53 »
 :hello:

Suis pas un spécialiste ATI / MW, mais il me semble que 'CAL' c'est plutôt pour les GPU plus anciens ?

As-tu sélectionné OpenCL dans tes préférences ?

Enfin, je dis ça, je dis rien : faut faire la manip proposée par SPICA ;) (sans oublier d'adapter les noms des fichiers si jamais ils ont changé)

Bon Amusement avec MW.

Chouette projet.

 :kookoo:
« Modifié: 08 novembre 2014 à 16:56 par Phil1966 »

tharkie

  • Messages: 41
  • P'tit Nouveau
  • *
Re : Question GPU sur Milkyway :)
« Réponse #6 le: 08 novembre 2014 à 17:21 »
Voilà :)

Je viens d'en profiter pour corriger mon précédent message en modifiant le app info en prenant en compte les dernières versions milqui :love:

Ça tourne chez moi parfaitement maintenant :yaya:

Ça torche incroyable le nombre d'unités... Et le traitement est ultra rapide, du coup, j'ai mis count @ 0.2 et je fais 5 Wu en moins de 6 minutes !


 :bounce:

Philippe06121966

  • Invité
Re : Question GPU sur Milkyway :)
« Réponse #7 le: 08 novembre 2014 à 17:27 »
Et un cruncher heureux de plus, un !

 :plusun: :yaya: :oki: :pakitooo:

tharkie

  • Messages: 41
  • P'tit Nouveau
  • *
Re : Question GPU sur Milkyway :)
« Réponse #8 le: 08 novembre 2014 à 17:33 »
 :lol: :love: :hello:

Merci à tous pour votre aide ;)

Et dire que j'ai fêté mes 15 ans de SETI en juin de cette année  :love: :love: :love:

JeromeC

  • CàA
  • Messages: 22712
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : Question GPU sur Milkyway :)
« Réponse #9 le: 09 novembre 2014 à 16:19 »
Ce topic, c'est typiquement l'un des grand "pourquoi" de l'AF (pas le seul certes, mais l'un des grands) : une équipe soudée et compétente de dépanneurs de boinc :D
Parce que c'était lui, parce que c'était moi.