Le Forum de l'Alliance Francophone

Nouvelles:

Auteur Sujet: MT [AF>Libristes] : le topic  (Lu 615986 fois)

0 Membres et 2 Invités sur ce sujet

Hors ligne Maeda

  • Boinc'eur devant l'éternel
  • *****
  • Messages: 2439
  •   
Réponse #4550 le: Aujourd'hui à 12:45
Le code HTTP 200 veut dire OK , es-tu sûr que c'est une erreur que tu obtiens ?

Le wget que tu testes qui fonctionne est sur le même système où le script s'exécute qui ne fonctionne pas ?

Suivant tes réponses aux questions ci-dessus : il semblerait que wget doit avoir le support SSL activé, peut-être ne l'est-il pas sur ton système ?
Quelle version de wget as-tu ?
wget -VSinon, force l'utilisation de l'HTTPS :
wget --secure-protocol TLSv2 TonLienHTTPS


Hors ligne [AF>Libristes] Dudumomo

  • Boinc'eur devant l'éternel
  • *****
  • Messages: 6103
  •   
    • Find your home in Saigon
    • E-mail
Réponse #4551 le: Aujourd'hui à 15:34
Salut
Le SSL est bien actif et en fait ca me donne: HTTP Header error : HTTP/2 200, ce qui n'est pas tres clair, mais ca n'arrive pas a telecharger en HTTPS

debian@vps-ffbb369e:~$ wget -V
GNU Wget 1.21.3 built on linux-gnu.

-cares +digest -gpgme +https +ipv6 +iri +large-file -metalink +nls
+ntlm +opie +psl +ssl/gnutls

Wgetrc:
    /home/debian/.wgetrc (user)
    /etc/wgetrc (system)
Locale:
    /usr/share/locale
Compile:
    gcc -DHAVE_CONFIG_H -DSYSTEM_WGETRC="/etc/wgetrc"
    -DLOCALEDIR="/usr/share/locale" -I. -I../../src -I../lib
    -I../../lib -Wdate-time -D_FORTIFY_SOURCE=2
    -I/usr/include/p11-kit-1 -DHAVE_LIBGNUTLS -DNDEBUG -g -O2
    -ffile-prefix-map=/build/wget-z9r8qt/wget-1.21.3=.
    -fstack-protector-strong -Wformat -Werror=format-security
    -DNO_SSLv2 -D_FILE_OFFSET_BITS=64 -g -Wall
Link:
    gcc -I/usr/include/p11-kit-1 -DHAVE_LIBGNUTLS -DNDEBUG -g -O2
    -ffile-prefix-map=/build/wget-z9r8qt/wget-1.21.3=.
    -fstack-protector-strong -Wformat -Werror=format-security
    -DNO_SSLv2 -D_FILE_OFFSET_BITS=64 -g -Wall -Wl,-z,relro -Wl,-z,now
    -lpcre2-8 -luuid -lidn2 -lnettle -lgnutls -lz -lpsl ../lib/libgnu.a

Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
<http://www.gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Originally written by Hrvoje Niksic <hniksic@xemacs.org>.
Please send bug reports and questions to <bug-wget@gnu.org>.

Le TLSv2 est invalide, mais en v1 je vais tester.
Edit: Pareil avec TLSv1
« Modifié: Aujourd'hui à 15:58 par [AF>Libristes] Dudumomo »

News & Tutorial on how to host your server: http://freedif.org