Auteur Sujet: [Résolu] Message du BM "negative FLOPs left -1.#IND00"  (Lu 1297 fois)

0 Membres et 1 Invité sur ce sujet

modesti

  • CàA
  • Messages: 16349
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Brocantes en Bourbonnais
[Résolu] Message du BM "negative FLOPs left -1.#IND00"
« le: 01 novembre 2011 à 16:28 »
 :kookoo:

Depuis ce matin, mon BoincManager me sort régulièrement pour toutes mes UT les messages d'erreur suivants :
Citer
01/11/2011 15:09:40   boincsimap   [error] 20111101.062703_1: negative FLOPs left -1.#IND00

01/11/2011 15:27:39   World Community Grid   [error] HFCC_target-7_02131308_target-7_0001_0: negative FLOPs left -1.#IND00

01/11/2011 16:13:03   Albert@Home   [error] p2030.20100913.G48.73+01.03.S.b1s0g0.00000_1160_1: negative FLOPs left -1.#IND00
01/11/2011 16:13:03   LHC@home 1.0   [error] w5_weak7a_collision_err_bb__57__s__64.31_59.32__10_12__6__36_1_sixvf_boinc50506_1: negative FLOPs left -1.#IND00
01/11/2011 16:13:03   malariacontrol.net   [error] wu_1158_34_71946_0_1320011947_0: negative FLOPs left -1.#IND00
01/11/2011 16:13:03   SETI@home Beta Test   [error] 12jl11aa.6761.39743.4.14.73.vlar_1: negative FLOPs left -1.#IND00
01/11/2011 16:13:03   yoyo@home   [error] evo_A1320017704-41-0_34.3MB_95.76_0: negative FLOPs left -1.#IND00
01/11/2011 16:13:03   Constellation   [error] trackjack_hyend_www.hybrid-triebwerk.de_2011-09-26_00_208316_1: negative FLOPs left -1.#IND00

C'est juste un extrait, il me fait ça pour toutes les UT de mes projets. Ces messages apparaissent par centaines de lignes en même temps.
D'un autre côté, le calcul se poursuit normalement et les UT se terminent et créditent.

Est-ce que je dois m'inquiéter ou juste laisser courir ?

Ordinateur : i7 860 - Win7 64b - Boinc 6.10.56
Précision : depuis hier, je suis censée redémarrer l'ordi pour cause d'installation d'un nouveau logiciel, mais j'attends que toutes les UT sans point de sauvegarde soient terminées avant de le faire.

Merci pour vos réponses :jap:
« Modifié: 01 novembre 2011 à 22:05 par modesti »

Viendez chez nous, cause qu'on est les meilleur(e)s :D


In memoriam Jip

jip

  • Invité
Re : Message du BM "negative FLOPs left -1.#IND00"
« Réponse #1 le: 01 novembre 2011 à 16:40 »
ça ressemble à une erreur arithmétique sur un flottant du C ou C++ ... dans le style NaN je crois ... produit par des opérations du style division par 0 sur flottant, ou sqrt(-1), etc ...

tu pourrais coller ton cc_config.xml ??

t'y aurais pas des flags de debug ??
« Modifié: 01 novembre 2011 à 16:56 par [AF>Libristes] Jip »

modesti

  • CàA
  • Messages: 16349
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Brocantes en Bourbonnais
Re : Message du BM "negative FLOPs left -1.#IND00"
« Réponse #2 le: 01 novembre 2011 à 17:40 »
A tes souhaits, Jip ! :D Tu me parles chinois là, mais C/C++ me dit qqch, car le nouveau soft a installé des trucs Gro$oft Visual C et/ou C+(+?). Ce qui pourrait expliquer.

Mon cc_config.xml :
<!--
This is the configuration file cc_config.xml of the BOINC core client.
For a complete list of all available options and logging flags and their
meaning see: http://boinc.berkeley.edu/trac/wiki/ClientMessages
-->
<cc_config>
  <options>
    <report_results_immediately>1</report_results_immediately>
    <no_priority_change>1</no_priority_change>
  </options>
  <log_flags>
    <task>1</task>
    <file_xfer>1</file_xfer>
    <sched_ops>1</sched_ops>
    <cpu_sched>0</cpu_sched>
    <cpu_sched_debug>0</cpu_sched_debug>
    <rr_simulation>0</rr_simulation>
    <debt_debug>0</debt_debug>
    <task_debug>0</task_debug>
    <work_fetch_debug>0</work_fetch_debug>
    <unparsed_xml>0</unparsed_xml>
    <state_debug>0</state_debug>
    <file_xfer_debug>0</file_xfer_debug>
    <sched_op_debug>0</sched_op_debug>
    <http_debug>0</http_debug>
    <proxy_debug>0</proxy_debug>
    <time_debug>0</time_debug>
    <http_xfer_debug>0</http_xfer_debug>
    <benchmark_debug>0</benchmark_debug>
    <poll_debug>0</poll_debug>
    <guirpc_debug>0</guirpc_debug>
    <scrsave_debug>0</scrsave_debug>
    <app_msg_send>0</app_msg_send>
    <app_msg_receive>0</app_msg_receive>
    <mem_usage_debug>0</mem_usage_debug>
    <network_status_debug>0</network_status_debug>
    <checkpoint_debug>0</checkpoint_debug>
  </log_flags>
</cc_config>

Viendez chez nous, cause qu'on est les meilleur(e)s :D


In memoriam Jip

jip

  • Invité
Re : Message du BM "negative FLOPs left -1.#IND00"
« Réponse #3 le: 01 novembre 2011 à 18:22 »
ah ! alors si t'en une mise à jour de la runtime vc++, vaudra mieux attendre de voir après ton redémarrage que l'installation se termine complètement.

car je ne vois pas de flags de debug là ...

par contre, bien compliquée la section log_flags, elle serait vide (mais faut laisser les 2 tags <log_flags> et </log_flags>, avec rien entre les 2) que ça changerait pas grand chose ...

modesti

  • CàA
  • Messages: 16349
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Brocantes en Bourbonnais
Re : Message du BM "negative FLOPs left -1.#IND00"
« Réponse #4 le: 01 novembre 2011 à 18:32 »
Euh, c'est pas moi qui ai installé Boinc sur cette bécane :desole: et je ne touche pas au cc_config. Ça aurait pu être celui de base que c'était pareil pour moi.

Je sais me faire obéir par les logiciels avec lesquels je travaille ou contourner les difficultés quand elles se présentent, mais je ne touche généralement pas aux "entrailles".

Viendez chez nous, cause qu'on est les meilleur(e)s :D


In memoriam Jip

modesti

  • CàA
  • Messages: 16349
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Brocantes en Bourbonnais
Re : Message du BM "negative FLOPs left -1.#IND00"
« Réponse #5 le: 01 novembre 2011 à 22:05 »
Reboot effectué : Non seulement le problème a disparu, mais en plus le BoincManager est à nouveau en train de se gaver de travail (j'étais descendue à 31 UT pour le i7) :bounce: :bounce: :bounce:

Viendez chez nous, cause qu'on est les meilleur(e)s :D


In memoriam Jip

jip

  • Invité
Re : [Résolu] Message du BM "negative FLOPs left -1.#IND00"
« Réponse #6 le: 01 novembre 2011 à 22:20 »
Ben voila ... elle est pas simple la vie (informatique) ? ..... bon ok, pas toujours ....  :siflotte:

Maurice Goulois

  • Messages: 3584
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Le forum des Electrons Libres de l'AF
Re : [Résolu] Message du BM "negative FLOPs left -1.#IND00"
« Réponse #7 le: 02 novembre 2011 à 02:29 »
Ca me fait penser à un problème de changement d'heure, le calcul des flops se basant sur le temps passé, hop -1h et paf temps négatif (mes 2 cts vite fait :))


modesti

  • CàA
  • Messages: 16349
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Brocantes en Bourbonnais
Re : [Résolu] Message du BM "negative FLOPs left -1.#IND00"
« Réponse #8 le: 02 novembre 2011 à 07:32 »
Hmmm, dans ce cas j'aurais dû avoir le même problème sur l'Athlon qui est resté allumé pendant le changement d'heure aussi :idtalacon:
Je sais qu'il a planté (ou pas, en tout cas j'avais perdu l'accès à distance et comme j'ai un écran noir quand je bascule dessus...) et que je l'ai redémarré, mais me souviens plus si c'était avant ou après le changement d'heure (salut Alois !)

Viendez chez nous, cause qu'on est les meilleur(e)s :D


In memoriam Jip

Maurice Goulois

  • Messages: 3584
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Le forum des Electrons Libres de l'AF
Re : [Résolu] Message du BM "negative FLOPs left -1.#IND00"
« Réponse #9 le: 02 novembre 2011 à 09:45 »
Je reconnais que c'est juste une idée dans le vent, si c'était aussi évident ça aurait dû impacter plus de monde, mais c'était une coincidence à noter.

modesti

  • CàA
  • Messages: 16349
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Brocantes en Bourbonnais
Re : [Résolu] Message du BM "negative FLOPs left -1.#IND00"
« Réponse #10 le: 02 novembre 2011 à 12:04 »
Toutafé.
Entre-temps j'ai vérifié : l'Athlon a redémarré le 31/10 à 18h et qq. Donc pas impossible que ça l'ait touché aussi - sauf que je n'ai rien vu car je ne m'en suis pas servie.

Viendez chez nous, cause qu'on est les meilleur(e)s :D


In memoriam Jip

Maurice Goulois

  • Messages: 3584
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Le forum des Electrons Libres de l'AF
Re : [Résolu] Message du BM "negative FLOPs left -1.#IND00"
« Réponse #11 le: 02 novembre 2011 à 12:32 »
En googlant un peu plus, j'ai trouvé très peu d’occurrences, c'est à priori un bug peu fréquent qui est lié au code (rr_sim.cpp) qui est la partie de l'ordonnanceur qui effectue une simulation. Le changement d'heure a pu jouer un rôle dans l'apparition de ce bug, mais ça reste un cas exceptionnel.