Auteur Sujet: MT [AF>Libristes] : le topic  (Lu 256154 fois)

0 Membres et 1 Invité sur ce sujet

[AF>Libristes] alain65

  • Messages: 63
  • Boinc'eur Junior
  • **
  •   
Re : Re : MT [AF>Libristes] : le topic
« Réponse #3400 le: 14 avril 2018 à 08:26 »

Bonjour Patrice  :kookoo:
j 'es abandonner, linux, d'apret m ont peut expériences mes cartes graphique r9 ne sont pas utile sous linux .  :cavachier:

J'y suis arrivé grâce à GuL. Regarde Ici : R9 sous Linux
Il y a certainement d'autres solutions, comme de retarder le démarrage du serveur Xorg, c'est a dire qu'il démarre après boinc.
Mais cette solution me convient bien.

 A + :hello:

In a world without walls and fences, who needs windows and gates?

Mes configs

[AF>libristes] patrice

  • Messages: 1604
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3401 le: 20 avril 2018 à 16:30 »
merci, alain65 :hello:
 mais j ai laisser tomber, sous ubuntun,16,04 mes carte r9 380 disposse pas de pilotes propriét
 la je fait un petit raide sur enigma@home. :gniak:
 le "secret" pour avoir des ut, clique sur, avoir des ut ; préférence de calcul,exécuter des applications test :kookoo:
qlique oui? :cavachier:
 les lapins sont en vue; :smak:
merci;un chat et un lapeins,
 :hello:
« Modifié: 20 avril 2018 à 18:17 par [AF>libristes] patrice »

[AF>Libristes] alain65

  • Messages: 63
  • Boinc'eur Junior
  • **
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3402 le: 21 avril 2018 à 02:29 »
Salut Patrice  :kookoo:

Oui c'est vrai pour ubuntu et fglrx  :/
Je n'avais pas fait attention que tu essayais avec ubuntu car il ne m'est pas venu à l'idée qu'on puisse cruncher avec
ubuntu qui est peut être la distribution, la plus gourmande en ressources (ce qui fait ça en moins pour boinc).
Effectivement, moi je suis sous debian 8 et fglrx est encore compatible .

Voici ce que j'ai trouvé chez ubuntu:
Citer
Le pilote fglrx est maintenant obsolète en 16.04, et nous recommandons ses alternatives open source (radeon et amdgpu). AMD a mis beaucoup de travail dans les pilotes, et nous avons rétroporté le code du noyau à partir de Linux 4.5 pour offrir une meilleure expérience.

Lors de la mise à niveau vers Ubuntu 16.04 d'une version précédente, le pilote fglrx et le xorg.conf seront supprimés, de sorte que le système soit configuré pour utiliser le pilote amdgpu ou le pilote radeon (en fonction du matériel disponible).

Dans une discussion sur une liste de diffusion, il est suggéré que les personnes qui ont réellement besoin du pilote fglrx doivent continuer à utiliser 14.04 jusqu'à ce que le pilote open source s'améliore:

AMD abandonne le support de leur pilote vidéo fglrx propriétaire blob inclus dans 16,04 LTS. La dernière version d'AMD ne peut pas être utilisée car elle est incompatible avec le nouveau serveur d'affichage x.org. La plupart des gens seront en mesure d'utiliser le pilote vidéo AMD open source, mais il existe quelques applications (certains jeux graphiques intensifs, l'extraction de bitcoin) pour lesquelles il est inadéquat. Les gens qui comptent sur de telles applications pourraient choisir de rester sur 14.04 LTS jusqu'à ce qu'un support adéquat atterrisse dans les pilotes vidéo AMD open source.

J'ai souligné "extraction de bitcoin" car nous utilisons les mêmes outils, donc sommes concernés aussi.
Mais cette partie : "jusqu'à ce qu'un support adéquat atterrisse dans les pilotes vidéo AMD open source", nous donne espoir.
ce qui voudrait dire qu'amd abandonne son pilote propriétaire (fglrx) pour en faire un libre (amdgpu) permettant le calcul.
Ce qui serai une excellente nouvelle pour nous libristes   ;) 

J'espère qu'amd va aller vite, car un jour ou l'autre je vais bien devoir passer à debian 9 et la je serai dans le même cas que toi
avec ta unbuntu 16.04...

les lapins sont en vue; :smak:
Si tu parle de enigma sur le FMT, y a encore de la marge pour les 3 pts...Bon courage  :hyperbon: :croisedoigts:

A+  :hello:

PS: je viens de voir ça: https://translate.google.com/translate?depth=1&hl=fr&rurl=translate.google.com&sl=auto&tl=fr&u=https://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-GPU-PRO-Linux-Beta-Driver%25E2%2580%2593Release-Notes.aspx sur le site AMD.
Le pilote amdgpu-pro est la version propriétaire du amdgpu. Et il "semblerai" (entre guillemets et au conditionnel) qu'il faille
accepter les conditions du Contrat de Licence Utilisateur Final ("CLUF") pour.....OpenCl ! Ce qui laisserai supposé que amdgpu-pro
gère l'OpenCl...Je pense que oui car il est écris que: "Installation du composant ROCm facultatif
Ce package de pilotes AMDGPU-Pro intègre le composant ROCm qui peut être installé en option pour l'exécution des applications Compute / OpenCL.
"
Quelqu'un utilise t' il ce pilote sur boinc?
Note a Patrice: ce pilote est compatible ubuntu 16.04 et pour ta carte R9 380.
In a world without walls and fences, who needs windows and gates?

Mes configs

GuL

  • Messages: 1217
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3403 le: 21 avril 2018 à 10:49 »
Ce package de pilotes AMDGPU-Pro intègre le composant ROCm qui peut être installé en option pour l'exécution des applications Compute / OpenCL.[/i]"
Quelqu'un utilise t' il ce pilote sur boinc?

J'ai testé sur une HD7950 et sur une autre carte de la même génération, et ça ne marche pas. La R9 380 est un poil plus récente et sera peut-être mieux gérée. Attention, les pilotes amdgpu nécessitent des kernels très récents pour être compatibles (4.11 de mémoire), et des options dans grub pour prendre en charge les cartes southern islands.

N'ayant pas mes notes sous les yeux, je vais essayer de m'en souvenir. L'explication qui suit risque donc d'être approximative. Pour faire marcher un driver graphique, il faut : 1) qu'il soit compatible avec le kernel et le matériel ; 2) qu'il soit compatible avec Xorg.

Si l'installation s'est mal passée et que l'affichage graphique n'est pas disponible, il n'y a pas d'autre choix que de démarrer en mode non-graphique, pour comprendre le problème. Pour ce faire, lors du démarrage de l'ordi, il faut aller dans grub, sélectionner la ligne du kernel qui nous intéresse, l'éditer avec la touche e, et rajouter 3 à la fin de la ligne linux, puis CTRL-X pour démarrer.

1) Pour vérifier s'il le driver est compatible avec le kernel
# lspci -nnk | grep -A3 VGALa commande doit afficher trois lignes : la description du matériel, le module utilisé et la liste des modules compatibles. Si le module qui nous intéresse est bien chargé, tout va bien. S'il n'est pas disponible, il n'est pas compatible, et il faut peut-être changer de version du kernel. S'il est disponible mais non chargé, il va falloir rajouter des options au démarrage du système. Le mieux est de les tester avant de redémarrer:
# modinfo amdgpu ---> liste tous les périphériques compatibles et les options possibles
# rmmod radeon --> désactive temporairement le module
# insmod amdgpu OPTIONS --> active l'autre module avec les options

Tant qu'on y est, on peut tester l'OpenCL
$ clinfo -l
$ clpeak

Si ça marche, on peut tester en ajoutant les options (pour blacklister radeon et pour charger correctement amdgpu) à la main dans le grub au démarrage, toujours en utilisant le mode non graphique, puis en modifiant /etc/default/grub et en appelant
# grub2-mkconfig -o /etc/grub2.cfg --> si on a un BIOS legacy
# grub2-mkconfig -o /etc/grub2-efi.cfg --> si on a un UEFI
Si ça ne marche pas, il faut continuer à creuser.

2) Une fois que le module est activé, on peut tester l'affichage graphique
$ startxSi ça marche, c'est gagné, sinon, il faut explorer le fichier /var/log/Xorg.0.log à la recherche d'erreurs liées au module. Éventuellement, il peut être nécessaire de rétrograder xorg et gnome

En résumé, pour faire marcher l'OpenCL avec les cartes AMD, ce n'est pas gagné d'avance et il peut être nécessaire de mettre les mains dans le cambouis.

Bon courage

[AF>Libristes] alain65

  • Messages: 63
  • Boinc'eur Junior
  • **
  •   
Re : Re : MT [AF>Libristes] : le topic
« Réponse #3404 le: 21 avril 2018 à 17:24 »
Salut GuL  :kookoo:

Merci pour ce tuto, je l'ai "marque pagé" pour le jour ou je devrais installer amdgpu-pro, ce qui va fatalement arriver car je ne
pourrai pas rester indéfiniment sous LMDE2 (debian 8).
J'ai testé sur une HD7950 et sur une autre carte de la même génération, et ça ne marche pas.
Je ne vois pas de HD dans la liste des cartes compatible avec amdgpu-pro (voir le lien dans mon message précédent)
Il n' y a que des série R et ça commence à la R7 260...ça vient certainement de la.. :/ Du coup pas d'autre choix que fglrx...Avec toutes
les obligations de version d'OS, kernel, xorg que ça implique..

Éventuellement, il peut être nécessaire de rétrograder xorg et gnome
Pour la version de xorg ou du kernel, donc de la distribution, je comprends, mais quelle est l'influence de l'environnement
de bureau? Je n'utilise pas gnome. Penses tu, par exemple, que la version de xfce ou kde ait de l'importance?

Encore merci pour les explications.

A +  :hello:
In a world without walls and fences, who needs windows and gates?

Mes configs

GuL

  • Messages: 1217
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : Re : Re : MT [AF>Libristes] : le topic
« Réponse #3405 le: 21 avril 2018 à 18:08 »
Salut GuL  :kookoo:

Je ne vois pas de HD dans la liste des cartes compatible avec amdgpu-pro (voir le lien dans mon message précédent)
Il n' y a que des série R et ça commence à la R7 260...ça vient certainement de la.. :/

Pour la version de xorg ou du kernel, donc de la distribution, je comprends, mais quelle est l'influence de l'environnement
de bureau? Je n'utilise pas gnome. Penses tu, par exemple, que la version de xfce ou kde ait de l'importance?
Salut Alain  :hello:

Le lien que tu donnais était pour la version 16.40. La version actuelle est la 17.50. Je ne sais plus si j'ai testé celle-là ou la 17.40. Bref, le support des cartes anciennes a été plus tardif. J'ai un doute sur le fait que le pilote marchait mais l'opencl non en tout cas.

Xfce, kde et gnome ne sont que les gestionnaires de fenêtre. Ils s'appuient sur Xorg ou Wayland qui sont l'affichage graphique. Les gestionnaires ont été mis à jours pour prendre en compte les mises à jour de Xorg. Les deux sont donc liés.

Je suppose que c'est un problème de dépendances mal établies, mais quand j'ai mis à jour gnome en ayant figé xorg, l'affichage ne marchait plus et j'ai dû réinstaller :/

A+

[AF>Libristes] alain65

  • Messages: 63
  • Boinc'eur Junior
  • **
  •   
Re : Re : Re : Re : MT [AF>Libristes] : le topic
« Réponse #3406 le: 22 avril 2018 à 08:15 »
Salut GuL  :kookoo:

Ils s'appuient sur Xorg ou Wayland qui sont l'affichage graphique. Les gestionnaires ont été mis à jours pour prendre en compte les mises à jour de Xorg. Les deux sont donc liés.

Merci pour la précision, donc dans certain cas si tu veux rétrograder de version d'xorg, tu est obligé de rétrograder de version d’environnement
de bureaux vu qu'ils sont liés...Ok j'ai compris    ;)

A+  :hello:
In a world without walls and fences, who needs windows and gates?

Mes configs

GuL

  • Messages: 1217
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : Re : Re : MT [AF>Libristes] : le topic
« Réponse #3407 le: 22 avril 2018 à 08:28 »
je ne pourrai pas rester indéfiniment sous LMDE2
Oui, le statut d'étudiant n'a qu'un temps (La Mutuelle Des Etudiants)  :D  :marcp: