Auteur Sujet: MT [AF>Libristes] : le topic  (Lu 327129 fois)

0 Membres et 1 Invité sur ce sujet

naz

  • CàA
  • Messages: 3147
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3550 le: 04 janvier 2019 à 18:05 »
Hello les amis  :kookoo: tout d'abord je vous souhaité une heureuse et très bonne année 2019. Je me permet de vous écrire afin que vous vous joignez à nous pour un PFA : http://statseb.boinc-af.org/fight.py?id=9
Bon crunch à toutes et tous  :hyperbon: :hyperbon:

[AF>Libristes] Dudumomo

  • Messages: 5829
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3551 le: 17 mars 2019 à 02:51 »
Salut les cruncheurs, belle perf sur le FMT ;)
News & Tutorial on how to host your server: http://freedif.org

[AF>Libristes] alain65

  • Messages: 118
  • Boinc'eur Junior
  • **
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3552 le: 17 mars 2019 à 08:19 »
Salut Dudumomo  :kookoo:

Oui belle perf, c'est la première fois que je vois ça depuis que je suis (du verbe suivre) le FMT.
Bravo a tous ceux qui œuvrent a cette performance :oki: 

 :hello:
In a world without walls and fences, who needs windows and gates?

Mes configs

naz

  • CàA
  • Messages: 3147
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3553 le: 17 mars 2019 à 12:13 »
Ah oui! Joli! On ne va pas se laisser faire  :cavachier: :cavachier: :cavachier:

erik

  • Messages: 1992
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3554 le: 06 avril 2019 à 17:45 »
 :hello:
Ubuntu 16.04 me propose une mise à jour du pilote nvidia. C'est la 384.130.
Quelqu'un l'a déjà testée?
   

[AF>Libristes] Pascal

  • CàA
  • Messages: 1885
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Forum de la M-T Libristes de L'AF
Re : MT [AF>Libristes] : le topic
« Réponse #3555 le: 06 avril 2019 à 19:10 »
 :kookoo: erik,


C'est vieux comme version. Je suis sur la 418.56 avec ubuntu 18.04 (bionic).


Je suis passé sur une version 384 en septembre 2017 mais suis revenu à la version 378 car elle ne m'a pas satisfait, la durée des calculs PPS de primegrid avait augmenté. C'était sur un ubuntu 16.04.

PC ; GNU/Linux ubuntu-mate 18.04 LTS (bionic) - AMD FX8350 x8 - 32Go DDR3 - GTX 1060 et GTX 1080 Ti
Raspberry Pi : RaspBian (dérivé de Debian Wheezy) - ARMv6 - carte flash SD 8Go
« Un peuple prêt à sacrifier un peu de liberté pour un peu de sécurité ne mérite ni l'une ni l'autre, et finit par perdre les deux. » Benjamin Franklin
« La droite dit : la première liberté, c'est la sécurité. Nous disons au contraire : la première sécurité, c'est la liberté. » Pierre Mauroy.

erik

  • Messages: 1992
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3556 le: 06 avril 2019 à 19:22 »
Méfiance donc...
Je verrai ça...  après le raid  :gniak:
Merci Pascal  :jap:

Après vérification, j'ai déjà la 384.130. Qu'est ce qu'il me veut le gestionnaire de mises à jour?  :??:
« Modifié: 06 avril 2019 à 19:32 par erik »
   

[AF>Libristes] alain65

  • Messages: 118
  • Boinc'eur Junior
  • **
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3557 le: 06 avril 2019 à 20:19 »
Bonjour Eric.

C'est une mise a jour du pilote 384 je l'ai eu aussi sur ma LM 18.3 base ubuntu 16.04.
Ce n'est pas une proposition de changement de version de pilote.
Certainement (la plupart du temps c'est ça) une mise à jour de sécurité. Faudrait regarder chez Nvidia s'il y a des infos, mais
ça m'étonnerai, ils ne sont pas très communicants la dessus.

J'en profite pour rappeler que la meilleur version (375 ,384 ,418 etc...) d'un pilote Nvidia, c'est celle qui a été faite pour
la carte graphique à l'époque de la carte, mettre une version supérieure ça peut marcher, mais c'est s'exposer à ce que
Nvidia ait retiré certaines fonctions de carte plus anciennes, voir même carrément retiré la prise en charge de la carte.
A ce sujet ils ont fait un gros ménage passé le 390, ce qui a occasioné de grosses surprises à des gens qui voulant toujours
être "up to date" ont installé une version 4xx sur du matos plus pris en charge.

Et ne pas s'inquiéter d'avoir une "vieille" version, tant qu'elles sont maintenues elles ont les mêmes mise à jour de
sécu que la dernière. Tu as le temps avec la 384.
« Modifié: 06 avril 2019 à 20:57 par [AF>Libristes] alain65 »
In a world without walls and fences, who needs windows and gates?

Mes configs

erik

  • Messages: 1992
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3558 le: 06 avril 2019 à 20:36 »
 :kookoo: alain65

Merci pour tous ces détails et il va falloir que j'en tienne compte, en effet j'ai 2x gtx 1080 Ti qui a disparu des étalages, en tout cas en neuf, il va donc falloir que je fasse attention avec les pilotes récents.
   

[AF>Libristes] alain65

  • Messages: 118
  • Boinc'eur Junior
  • **
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3559 le: 06 avril 2019 à 20:56 »
Bon... des 1080 c'est pas vieux, le 418  va bien.
Pour savoir regarde sur cette page du site Nvidia. Téléchargements de pilotes NVIDIA
Le pilote proposé est 100% fonctionnel.
Quand je parle de cartes "anciennes" c'est par exemple une 9800 GTX, la c'est pas plus que le 340 par exemple.
Jusqu'aux séries 900 ils n'ont pas encore fait le ménage. mais ça va venir  :siflotte:
In a world without walls and fences, who needs windows and gates?

Mes configs

erik

  • Messages: 1992
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3560 le: 07 avril 2019 à 06:51 »
Je ne suis pas trop pressé pour changer de pilote ni d'upgrader vers la 18.04 d'ubuntu.
J'ai un pc sous ubuntu 18.04 qui me fait plein de misères.


   

[AF>Libristes] alain65

  • Messages: 118
  • Boinc'eur Junior
  • **
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3561 le: 07 avril 2019 à 06:58 »
Passes à debian, ça fait longtemps que j'ai abandonner ubuntu.
Surtout que vu sa "lourdeur" et son utilisation des ressources c'est pas le top pour le crunch :/
Pis pour un "libriste" c'est quand même préférable... :jtevoivnir:
Avec debian tu n'est pas dépaysé car ubuntu c'est du debian à l'origine, c'est les mêmes commandes.
Pour le pilote Nvidia, si tu n'as pas de problèmes, alors aucune raison d'en changer. C'est ma politique, comme pour
les noyaux: si ça marche on ne touche pas  :sun:
In a world without walls and fences, who needs windows and gates?

Mes configs

JeromeC

  • CàA
  • Messages: 22731
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3562 le: 07 avril 2019 à 12:57 »
C'est ma politique, comme pour les noyaux: si ça marche on ne touche pas  :sun:
C'est clair que c'est une très bonne politique mais elle est difficile à appliquer à l'époque où l'on vit avec tout qui te pousse tout le temps vers la "nouveauté"... on perd le goût de l'ancien :D
Parce que c'était lui, parce que c'était moi.

Matt11

  • Messages: 639
  • Boinc'eur Respectable
  • ****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3563 le: 07 avril 2019 à 13:24 »
L'éternel dilemme entre nouveauté et stabilité auquel il faut rajouter la sécurité entre les deux  :coffeetime:
Pour ma part je suis aussi partisan de la stabilité

Ubuntu Mate 18.04  Intel core i7 6700K 4x4.0GHz 16Gb Nvidia Geforce GTX 1070

JeromeC

  • CàA
  • Messages: 22731
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3564 le: 07 avril 2019 à 14:57 »
Tu as raison de rappeler la sécurité, c'est bien souvent une raison importante pour faire un upgrade par les temps qui courent :)

Mais il y a aussi la régression, éternelle amie des développeurs passionnés et ennemie de la stabilité :D
Parce que c'était lui, parce que c'était moi.

[AF>Libristes] alain65

  • Messages: 118
  • Boinc'eur Junior
  • **
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3565 le: 08 avril 2019 à 05:54 »
Bon, l'attrait de la nouveauté, moi je veux bien, même si je ne suis pas de ce genre la. :cpopossib:
Surtout si ça rend instable ma machine...
Mais le critère de la sécurité n'est pas recevable, car tant que vous restez sur un noyau, ou un pilote, maintenu, vous avez
toutes les mises à jour de sécurité.
La preuve je suis toujours sur le 3.16 sur une de mes machines et il a reçu le patch "spectre/meldown" comme les autres
et j'ai régulièrement des majs comme sur mes 4.10, 4.15 et 4.19.
La dernière mise à jour du pilote Nvidia 384, c'est une maj de sécu, pas pour y ajouter une nouvelle carte, vu que ça c'est
le dernier pilote qui s'en charge (avec au passage le retrait d'anciennes cartes pour faire de la place aux nouvelles).
In a world without walls and fences, who needs windows and gates?

Mes configs

JeromeC

  • CàA
  • Messages: 22731
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3566 le: 08 avril 2019 à 11:03 »
Ceci n'est pas valide pour "tout système" : s'ils appliquent une politique de mise à jour uniquement des "versions majeures" (sur une ou deux versions), tu peux te dire "j'ai une v1 à jour ou une v2 à jour" (comme cela a l'air d'être le cas avec vos versions de pilotes graphiques ou de noyaux linux, tant mieux), mais souvent t'es obligé de manger la v1.1, la 1.2, la 1.3 si tu veux avoir une "v1 à jour", et pareil avec ta v2, et ça va immanquablement inclure les "nouveautés" que tu le veuilles ou non, qui vont apporter les nouveaux bugs...

Donc dans cas cas tu n'as plus que le choix de rester dans ta version pour ne pas risquer de choper ces "évolutions", et de ne pas bénéficier de MaJ de sécurité...
Parce que c'était lui, parce que c'était moi.

Matt11

  • Messages: 639
  • Boinc'eur Respectable
  • ****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3567 le: 08 avril 2019 à 21:06 »
Bon, l'attrait de la nouveauté, moi je veux bien, même si je ne suis pas de ce genre la. :cpopossib:
Surtout si ça rend instable ma machine...
Mais le critère de la sécurité n'est pas recevable, car tant que vous restez sur un noyau, ou un pilote, maintenu, vous avez
toutes les mises à jour de sécurité.
La preuve je suis toujours sur le 3.16 sur une de mes machines et il a reçu le patch "spectre/meldown" comme les autres
et j'ai régulièrement des majs comme sur mes 4.10, 4.15 et 4.19.
La dernière mise à jour du pilote Nvidia 384, c'est une maj de sécu, pas pour y ajouter une nouvelle carte, vu que ça c'est
le dernier pilote qui s'en charge (avec au passage le retrait d'anciennes cartes pour faire de la place aux nouvelles).

Je parlais pas forcément du noyau. Les logiciels aussi sont soumis au dilemme nouveauté/sécurité/stabilité.
Si on prend par exemple Thunderbird, je ne crois pas qu'on puisse rester sur une veille version en sécurité. On est donc obligé de subir les nouveautés pour rester sûr (chose qui n'est pas forcément vrai pour Firefox avec sa version ESR).
Et ce n'est pas un cas particulier, la plupart des devs ne séparent pas les màj "nouveauté" et "sécurité".

Ubuntu Mate 18.04  Intel core i7 6700K 4x4.0GHz 16Gb Nvidia Geforce GTX 1070

JeromeC

  • CàA
  • Messages: 22731
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3568 le: 08 avril 2019 à 21:17 »
Ca serait la solution en fait, avoir toujours 2 branches parallèles de déploiement, pour les évols et les fix. Mais c'est ptet ingérable.

C'est ce que fait Windows non ? t'as toute une liste de patchs clairement estampillés sécurité ou pas, et tu peux choisir.
 
Alors que sur linux de ce que je constate sur mes 2 petites VM t'as pas le choix, tu fais "update" puis "upgrade" et il balance la purée...

Pas plus que sur macOS évidemment, c'est un gros package à chaque fois.
Parce que c'était lui, parce que c'était moi.

JeromeC

  • CàA
  • Messages: 22731
  • Boinc'eur devant l'éternel
  • *****
  •   
Parce que c'était lui, parce que c'était moi.

erik

  • Messages: 1992
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3570 le: 16 avril 2019 à 20:39 »
J'en ai lancé une comme ça juste pour rire: plantée  :D

https://lhcathome.cern.ch/lhcathome/result.php?resultid=221113884

edith: je viens de voir qu'il me manquait des trucs. Je vais réessayer
edith 2 le retour: j'ai suivi les instructions données pour installer  "CernVM-FS client". mais ça plante toujours, après tout c'est du bêta  :siflotte:

 https://lhcathome.cern.ch/lhcathome/result.php?resultid=221114485

 :cpopossib:
« Modifié: 16 avril 2019 à 21:08 par erik »
   

modesti

  • CàA
  • Messages: 15706
  • Boinc'eur devant l'éternel
  • *****
  •   
    • Brocantes en Bourbonnais
Re : MT [AF>Libristes] : le topic
« Réponse #3571 le: 17 avril 2019 à 00:27 »
Si je regarde le stderr de ta 2e tâche, erik, ça ne viendrait pas de chez eux? :??:
Citer
18:58:24 2019-04-16: cranky-0.0.28: [ERROR] /cvmfs/grid.cern.ch/vc/containers/runc does not exist.

Viendez chez nous, cause qu'on est les meilleur(e)s :D


In memoriam Jip

JeromeC

  • CàA
  • Messages: 22731
  • Boinc'eur devant l'éternel
  • *****
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3572 le: 17 avril 2019 à 09:30 »
L'install du bousin est complexe, y'a les instructions d'installation sur le site du CERN-machin (et déjà à la base y'en a une pelletée) PUIS des trucs à faire derrière détaillés sur le topic du forum LHC...
Parce que c'était lui, parce que c'était moi.

[AF>Libristes>Jip] Elgrande71

  • Gentil admin
  • Messages: 4749
  • Boinc'eur devant l'éternel
  • *******
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3573 le: 21 avril 2019 à 20:59 »
Je vais regarder cela de mon côté et je vous tiens au jus .
Debian - Distribution GNU/Linux de référence
Parabola GNU/Linux - Distribution GNU/Linux Libre
Solus

Jabber elgrande71@jit.si

[AF>Libristes>Jip] Elgrande71

  • Gentil admin
  • Messages: 4749
  • Boinc'eur devant l'éternel
  • *******
  •   
Re : MT [AF>Libristes] : le topic
« Réponse #3574 le: 21 avril 2019 à 22:33 »
Après avoir suivi les recommandations de la page suivante :

https://lhcathomedev.cern.ch/lhcathome-dev/forum_thread.php?id=447&postid=5830#5830

Voici un petit résumé pour moi ( Debian 9 Stretch ) :

Installation CVMFS

su ( pour se mettre en superutilisateur root )
wget https://ecsft.cern.ch/dist/cvmfs/cvmfs-release/cvmfs-release-latest_all.deb
dpkg -i cvmfs-release-latest_all.deb
rm -f cvmfs-release-latest_all.deb
apt update
apt install cvmfs

Paramétrage divers ( toujours en superutilisateur )

wget https://lhcathomedev.cern.ch/lhcathome-dev/download/default.local -O /etc/cvmfs/default.local
mkdir -p /etc/auto.master.d/
echo "/cvmfs /etc/auto.cvmfs" > /etc/auto.master.d/cvmfs.autofs
systemctl restart autofs
cvmfs_config probe
echo "kernel.unprivileged_userns_clone = 1" >>  /etc/sysctl.conf
sysctl -p
gpasswd -a boinc cvmfs

Redémarrage du client BOINC
systemctl restart boinc-client

Pour l'instant, ma première unité se calcule .

 :croisedoigts:
« Modifié: 22 avril 2019 à 09:40 par [AF>Libristes>Jip] Elgrande71 »
Debian - Distribution GNU/Linux de référence
Parabola GNU/Linux - Distribution GNU/Linux Libre
Solus

Jabber elgrande71@jit.si