Auteur Sujet: GPUGrid  (Lu 197278 fois)

0 Membres et 1 Invité sur ce sujet

Damien

  • Messages: 2064
  • Boinc'eur devant l'éternel
  • *****
    • EDLS
GPUGrid
« le: 18 juillet 2008 à 09:54 »
Jusqu'ici il existait PS3Grid http://www.ps3grid.net/ permettant de faire fonctionner BOINC sur les PlayStation

Après des 1er tests concluants cette seamine, il existe désormais GPUGrid http://www.gpugrid.net/ pour l'utilisation de BOINC sur les processeurs graphiques, c'est toujours pour la recherche de simulations biomoléculaire.

Les comptes et équipes précédentes ont été automatiquement transférés sur cette nouvelle URL. L'Alliance Francophone est ici: http://www.gpugrid.net/team_display.php?teamid=6



Pour plus de détail vous pouvez lire la page sur le portail ici : http://boinc-af.org/projets-sciences-de-la-vie/1040-gpugrid.html


Publication d'octobre 2014 :  http://www.gpugrid.net/forum_thread.php?id=3910&nowrap=true#38742


Ils ont mis en ligne l'application cuda 4.2 qui est apparemment sensiblement plus rapide...

D'après l'admin, Noelia est une nouvelle étudiante en doctorat : http://www.gpugrid.net/forum_thread.php?id=3073#26266

Pour mémoire, l'équipe du projet se présente ici : http://www.gpugrid.net/about.php
« Modifié: 29 octobre 2014 à 18:56 par Polynésia »


Damien

  • Messages: 2064
  • Boinc'eur devant l'éternel
  • *****
    • EDLS
GPUGrid
« Réponse #1 le: 18 juillet 2008 à 10:06 »
Les premiers essais par des inscrits sur PS3Grid ont démarré seulement cette semaine sous Linux 64b. Il en est question sur ce forum à partir du message suivant: http://forum.boinc.fr/boinc/BlaBla/gpu-bientot-boinc-sujet_548_6.htm#t31735

Le portage de BOINC sur les GPU a été possible grâce à l'administrateur et aux modérateurs du projet PSGrid et grâce à une étroite collaboration avec les développeurs de la plate-forme BOINC, en particulier David Anderson de l'Université de Berkeley et Stefan et Keith de la communauté BOINC. L'administrateur du site souligne également l'aide importante apportée par Nvidia.

Une illustration qui en dit long sur la puissance de calcul que les projets BOINC vont pouvoir tirer des GPU:





Jim PROFIT

  • Messages: 889
  • Boinc'eur Respectable
  • ****
  •   
GPUGrid
« Réponse #2 le: 18 juillet 2008 à 12:39 »
Il s'agit du même site que PS3Grid!

J'ai essayé de me connecter avec mes identifiants, et j'arrive sur mon compte, donc pas grand chose de neuf, hormis l'adresse!

:hello:

Damien

  • Messages: 2064
  • Boinc'eur devant l'éternel
  • *****
    • EDLS
GPUGrid
« Réponse #3 le: 18 juillet 2008 à 13:26 »
Citation de: Jim PROFIT
Il s'agit du même site que PS3Grid!

J'ai essayé de me connecter avec mes identifiants, et j'arrive sur mon compte, donc pas grand chose de neuf, hormis l'adresse!

:hello:


En même temps parfois, c'est comme ça que débute un nouveau site, différent du précédent (ABC@Home qui a pratiquement succédé à ABC@Home/Beta): au début tout semble identique, sauf l'URL et éventuellement la page d'accueil (déjà ici les logos sont légèrement différents):



EDIT: Mais il semble être trop tôt pour rejoindre le projet via cette nouvelle URL


RLDF

  • Messages: 4492
  • Boinc'eur devant l'éternel
  • *****
  •   
    • avatar ?
GPUGrid
« Réponse #4 le: 27 juillet 2008 à 17:00 »
j'ai des difficultés a compiler le driver cuda nvidia
mon uname -r sort bien : 2.6.18-6-amd64
je suis donc en linux64
pourtant quand je lance sh NVIDIA-Linux-x86_64-177.13-pkg2.run il répond :
line 791: ./nvidia-installer: No such file or directory
je le lance en -x pour juste décompresser et le fichier existe pourtant bien
je lance ./nvidia-installer et même erreur  :(
vous avez déjà rencontré ce problème ?

XTC_ZeuZ

  • Invité
GPUGrid
« Réponse #5 le: 28 juillet 2008 à 11:48 »
Prend le 173.14, pas besoin de le compiler, tu le mets sur le bureau

Tu te log en mode console, tu stops x puis tu te rend dans sur le bureau avec la commande CD , là tu fais sh NVIDIA-Linux-x86_64-173.14-pkg2.run , tu auras un ecran d'installation tu fais ce qu'il faut puis une fois terminé il te reste juste à rebboter le pc

C'est la marche à suivre pour ubuntu et fedora, je sais pas sous debian si c'est pareil je connais pas

Corran Horn

  • Messages: 1109
  • Boinc'eur devant l'éternel
  • *****
  •   
GPUGrid
« Réponse #6 le: 29 juillet 2008 à 22:01 »
Je me suis attché au projet. J'ai bien installé la dernière version NVIDIA (linux 64) machin tout ça mais il me dit que mon ne correspond pas.

Comment on fait pour copier unligne de l'écran des messages ?

:jap:

XTC_ZeuZ

  • Invité
GPUGrid
« Réponse #7 le: 29 juillet 2008 à 22:06 »
Tu selectionne la ligne dans boinc puis tu clics sur copier les messages selectionner, il te restera plus qu'à coller ici

Sinon quelle version de driver? modèle de la carte graphique? version de boinc? (il te faut la 6.3.3)

Corran Horn

  • Messages: 1109
  • Boinc'eur devant l'éternel
  • *****
  •   
GPUGrid
« Réponse #8 le: 29 juillet 2008 à 22:23 »
Voila justement je revenais pour dire ça. Je n'avais pas pris la version pre-release de Boinc.

La première wu tourne depuis quelques minutes ;)

:jap:

Corran Horn

  • Messages: 1109
  • Boinc'eur devant l'éternel
  • *****
  •   
GPUGrid
« Réponse #9 le: 29 juillet 2008 à 22:24 »
Niveau RAC ça donne quoi GPU Grid ?

Corran Horn

  • Messages: 1109
  • Boinc'eur devant l'éternel
  • *****
  •   
GPUGrid
« Réponse #10 le: 29 juillet 2008 à 22:42 »
La vache la wu fait 17h mais j'ai jusqu'à samedi pour la calculer :crazy:

Corran Horn

  • Messages: 1109
  • Boinc'eur devant l'éternel
  • *****
  •   
GPUGrid
« Réponse #11 le: 29 juillet 2008 à 22:54 »
Question bête. Ca gère le "sli" ce projet ?


XTC_ZeuZ

  • Invité
GPUGrid
« Réponse #12 le: 30 juillet 2008 à 00:20 »
17h c'est une estimation, ça met 15h sur une 9600GT, 12h sur une 8800GT, après les 8600 et consort mieu vaut éviter :)

Une 9600GT frôle les 3000 de rac et 3700 une 8800GT

Pour le sli oui ça gère mais il faut le désactiver pour que ça marche, ça utilise également 2 cores de ton processeur

Corran Horn

  • Messages: 1109
  • Boinc'eur devant l'éternel
  • *****
  •   
GPUGrid
« Réponse #13 le: 30 juillet 2008 à 07:21 »
On verra le temps de la wu. A priori je devrais m'en tenir là. L'ordinateur est ralenti par le calcul et je vois de fortes lenteurs lorsque je passe d'une fenêtre à une autre :/

Les vidéos sont également plus lente.

Est ce que ça fait la même chose avec des cartes plus puissantes ?

Corran Horn

  • Messages: 1109
  • Boinc'eur devant l'éternel
  • *****
  •   
GPUGrid
« Réponse #14 le: 30 juillet 2008 à 07:46 »
Après une heure de calcul je suis à 2.7%. Je devrais donc mettre environ 35 h pour calculer la wu. Je n'ai que jusqu'à samedi ça va faire juste :/

XTC_ZeuZ

  • Invité
GPUGrid
« Réponse #15 le: 30 juillet 2008 à 10:26 »
J'avais pareil, l'utilisation de l'os était un peu ralentie (j'avais quand même désactivé les effets graphiques ça allait un poil mieu) , ça doit venir des drivers parce que sous vista avec aero aucun ralentissement quand je faisais du F@H GPU , c'est vrai que c'est un peu "lourd" mais j'espère que ça va s'améliorer avec d'autres drivers

35h tu as quoi comme carte graphique? 8600GTS? je vois que ça qui pourrai faire ce temps là

Corran Horn

  • Messages: 1109
  • Boinc'eur devant l'éternel
  • *****
  •   
GPUGrid
« Réponse #16 le: 30 juillet 2008 à 13:19 »
Pour la carte graphique c'est fort probable. Du coup au vu de l'utilisation de la machine et vu le fait que je n'aurais pas le temps de finir la wu à temps j'ai coupé la bestiole.

A la base c'est une machine pour surfer et faire de la burautique. Elle a été achetée en aout 2007 et j'ai mis dessus un Q6600 (pour seti) et une 8600 (GT ou GTS) en passif car je n'allais pas jouer à grand chose en OS full linux ;)

Bon par contre je reste en stand by. Si jamais les lenteurs disparaissent je pourrais très bien changer de carte graphique ;)

Jim PROFIT

  • Messages: 889
  • Boinc'eur Respectable
  • ****
  •   
GPUGrid
« Réponse #17 le: 07 août 2008 à 11:40 »
Bon mes premiers pas avec le calcul GPU ne sont pas très concluant pour le moment!

Pour le moment, on va dire que je galère un peu!
Après un début de test sur un laptop équipé d'une GT8700M (je sais c'est pas terrible!), j'ai basculé Ubuntu sur une machine équipé d'une GT260!
Et plantage au bout de quelques minutes de toutes les UT!
Attente de 24H pour récupérer des WUS, et maintenant Ubuntu se fige complètement!

Bon pour info, n'ayant pas la possibilité sur mes machines de passer en dual-boot Win-Linux (Raid ICH8 et 9), j'ai fait une install sur un disque USB. Donc je pense que mon install faite à partir du laptop et ensuite branchée sur un fixe, doit foirer un peu!

Si jamais quelqu'un a une idée avant que je refasse mon install ce soir!
Bon en même temps Linux n'est pas ce que je connais de mieux, donc déjà je galère un peu!

Par ailleurs, est-il normal que depuis l'install des drivers, l'écran de logon m'oblige à taper en qwerty?

:hello:

rom_185

  • Messages: 5215
  • Boinc'eur devant l'éternel
  • *****
  •   
GPUGrid
« Réponse #18 le: 07 août 2008 à 12:15 »
Citer
Par ailleurs, est-il normal que depuis l'install des drivers, l'écran de logon m'oblige à taper en qwerty?
système>préférences>clavier ;).
BOINC, les grandes énigmes de la science résolues en 2 temps 3 calculs
I reject your reality and substitue my own

Jim PROFIT

  • Messages: 889
  • Boinc'eur Respectable
  • ****
  •   
GPUGrid
« Réponse #19 le: 07 août 2008 à 12:38 »
Citation de: rom_185
Citer
Par ailleurs, est-il normal que depuis l'install des drivers, l'écran de logon m'oblige à taper en qwerty?
système>préférences>clavier ;).


Non ça c'est déjà fait quand même!!
J'ai mis français par défaut mais rien à faire!

:hello:


RLDF

  • Messages: 4492
  • Boinc'eur devant l'éternel
  • *****
  •   
    • avatar ?
GPUGrid
« Réponse #20 le: 07 août 2008 à 12:47 »
tu as installé une ubuntu32 ou 64 bits ? version 7.10 ou 8.04 ?

Jim PROFIT

  • Messages: 889
  • Boinc'eur Respectable
  • ****
  •   
GPUGrid
« Réponse #21 le: 07 août 2008 à 12:50 »
La version installé est Ubuntu 8.04.1 64 bits avec les drivers récupéré chez Nvidia, donc 177.x, de mémoire, et Boinc 6.3.5.

:hello:

RLDF

  • Messages: 4492
  • Boinc'eur devant l'éternel
  • *****
  •   
    • avatar ?
GPUGrid
« Réponse #22 le: 07 août 2008 à 14:02 »
et donc c'est a l'install du pilote CUDA nvidia que ton clavier est passé en qwerty ?
ça ne le fait pas en mode console ? (ctrl+alt+F1)
on dirait un souci dans le /etc/X11/xorg.conf

Jim PROFIT

  • Messages: 889
  • Boinc'eur Respectable
  • ****
  •   
GPUGrid
« Réponse #23 le: 07 août 2008 à 14:33 »
Citation de: Jim PROFIT
La version installé est Ubuntu 8.04.1 64 bits avec les drivers récupéré chez Nvidia, donc 177.x, de mémoire, et Boinc 6.3.5.

:hello:


Citation de: RLDF
et donc c'est a l'install du pilote CUDA nvidia que ton clavier est passé en qwerty ?
ça ne le fait pas en mode console ? (ctrl+alt+F1)
on dirait un souci dans le /etc/X11/xorg.conf


Je ne sais plus.
Je crois avoir vu cela au démarrage, mais effectivement en mode console, je ne me souviens pas du problème!

Je verrai cela ce soir!

:hello:

rom_185

  • Messages: 5215
  • Boinc'eur devant l'éternel
  • *****
  •   
BOINC, les grandes énigmes de la science résolues en 2 temps 3 calculs
I reject your reality and substitue my own