Le Forum de l'Alliance Francophone

Nouvelles:

  • Projet du Mois FB: Asteroids@home

Auteur Sujet: Les applications 64 bits  (Lu 113583 fois)

0 Membres et 1 Invité sur ce sujet

Hors ligne Markken

  • Boinc'eur devant l'éternel
  • *****
  • Messages: 1186
  •   
Réponse #200 le: 27 July 2007 à 08:31
Ok, j'essaye ce soir.  :sol:



Hors ligne Markken

  • Boinc'eur devant l'éternel
  • *****
  • Messages: 1186
  •   
Réponse #201 le: 27 July 2007 à 20:01
Voila le message:

ven 27 jui 2007 19:56:38 CEST|climateprediction.net|Sending scheduler request: Requested by user
ven 27 jui 2007 19:56:38 CEST|climateprediction.net|(not requesting new work or reporting completed tasks)
ven 27 jui 2007 19:56:43 CEST|climateprediction.net|Scheduler RPC succeeded [server version 509]
ven 27 jui 2007 19:56:43 CEST|climateprediction.net|Message from server: platform 'x86_64-pc-linux-gnu' not found
ven 27 jui 2007 19:56:43 CEST|climateprediction.net|Deferring communication for 1 days 0 hr 0 min 0 sec
ven 27 jui 2007 19:56:43 CEST|climateprediction.net|Reason: requested by project

Je suis vraiment hyper nul, que dois je faire ?  :??:  (pourtant les autres projets fonctionnent! :heink: )



Hors ligne [AF>Libristes>Jip] otax

  • Animateur fanatique
  • Boinc'eur devant l'éternel
  • *****
  • Messages: 5661
  •   
    • Le Libre  : Linux , Boinc et les autres  ;-)
    • E-mail
Réponse #202 le: 27 July 2007 à 20:13
Tu t'es trompé de projet.
Là tu es sur CPDN !

C'est seulement CPDNbeta qui donne en Linux64.
Le site est celui là :

http://climateapps1.oucs.ox.ac.uk/beta/



Hors ligne Markken

  • Boinc'eur devant l'éternel
  • *****
  • Messages: 1186
  •   
Réponse #203 le: 27 July 2007 à 20:27
Oui effectivement, c'est du rapide... 1/2s et hop 100%! avec erreur bien sur.  :(



Hors ligne [AF>Libristes>Jip] otax

  • Animateur fanatique
  • Boinc'eur devant l'éternel
  • *****
  • Messages: 5661
  •   
    • Le Libre  : Linux , Boinc et les autres  ;-)
    • E-mail
Réponse #204 le: 27 July 2007 à 21:08
Ton PC est overclocké ?
Tu tournais sous CD live Ubuntu ?

Si tu peux aussi me mettre un mien vers la wu foirée (comme Amiloz) , je mettrai un post sur le board, en montrant 4 config différentes (2 à moi plus les 2 votres)  qui plantent çà devrait faire réagir.

Merci  :jap:




Hors ligne Markken

  • Boinc'eur devant l'éternel
  • *****
  • Messages: 1186
  •   
Réponse #205 le: 27 July 2007 à 21:32
non pas oc.
le live cd, c'était avant... maintenant en dual boot, s'il vous plait.  :D
http://climateapps1.oucs.ox.ac.uk/beta/result.php?resultid=11777



Hors ligne [AF>Libristes>Jip] otax

  • Animateur fanatique
  • Boinc'eur devant l'éternel
  • *****
  • Messages: 5661
  •   
    • Le Libre  : Linux , Boinc et les autres  ;-)
    • E-mail
Réponse #206 le: 27 July 2007 à 21:41
Tu me fais plaisir toi !  :sol:

OK, je vais pouvoir faire mon post  ;)



Hors ligne Markken

  • Boinc'eur devant l'éternel
  • *****
  • Messages: 1186
  •   
Réponse #207 le: 27 July 2007 à 21:46
Reste le wifi....  :pt1cable:  je vais poster sur le topic linux  :hello: .



Hors ligne [AF>Libristes>Jip] otax

  • Animateur fanatique
  • Boinc'eur devant l'éternel
  • *****
  • Messages: 5661
  •   
    • Le Libre  : Linux , Boinc et les autres  ;-)
    • E-mail

Hors ligne veaux

  • Boinc'eur Confirmé
  • ***
  • Messages: 425
  •   
Réponse #209 le: 28 July 2007 à 16:41
Leiden ca chiait beaucouo le semaine derniere mais maintenant beaucoup moins meme avec trajou (enfin chez moi a ce que je vois).

Enfin g qd meme abandonne Leiden car j'ai une tonne de WU en pending avec leur contre partie "NOT SEND" donc... (meme avec WCG je n'ai jamais eu de pending si long)

Kubuntu 7.04 64bits sinon, ca fait un mois que je suis converti et j'en suis bien satisfait. (y'a que le pb des jeux et de ma camera num qui marche pas :()



Hors ligne Amiloz

  • Boinc'eur Confirmé
  • ***
  • Messages: 475
Réponse #210 le: 29 July 2007 à 01:35
Citation de: otax
OK.

Message posté :
http://climateapps1.oucs.ox.ac.uk/beta/forum_thread.php?id=137&nowrap=true#1151

J'ai fait la manip préconisée par l'admin ...
Pour mémoire, on modifie la taille de la   :??:  stack:
dans un terminal :
Citer
ulimit -s 65536

Mais le problème persiste ! :fou:



Hors ligne [AF>Libristes>Jip] otax

  • Animateur fanatique
  • Boinc'eur devant l'éternel
  • *****
  • Messages: 5661
  •   
    • Le Libre  : Linux , Boinc et les autres  ;-)
    • E-mail
Réponse #211 le: 29 July 2007 à 11:15
moi j'avais déjà mis çà dans mon script de lancement :

Citer
ulimit -s unlimited


Je l'avais oublié !
Mais , bon çà marchait pas non plus  :heink:



Hors ligne claude

  • Membre d'honneur
  • Boinc'eur Respectable
  • *
  • Messages: 993
  •   
Réponse #212 le: 02 August 2007 à 00:10
Bon alors voilà,

comme vous le savez sûrement, le client boinc est normalement "capable de télécharger" des applications 32bits sur un système 64bits, à condition toutefois que votre système le supporte (sous linux il faut le package linux32).

ça fait quelques jours que je cherchais en vain pourquoi je ne récupérais pas d'appli 32bits alors que j'avais bien le paramètre correct dans client_state.xml : i686-pc-linux-gnu.  
J'ai enfin compris, enfin je crois, en regardant dans les logs SVN des sources  de boinc.
En fait, ce paramètre fonctionne mais il faut que les serveur auxquels le client se connecte soient à jour d'une version d'après le 19 avril 2007 ; c'est à cette date que Berkeley a fait évoluer le système pour permettre de définir plusieurs compatibilités processeurs simultanées ainsi que pour linux64-32, et pour ça ils ont ajouté/modifié ces paramètres xml entre autre (la balise a été remplacée par en début d'année), d'où des incompréhension entre client et serveur...
Je problème doit être similaire avec Windows vista ou xp64...

Je n'ai pas trouvé comment connaître la version des serveurs. au moins pour avoir une idée du retard des mise à jour...voire pour trouver une solution alternative...

si j'ai le temps, je rechercherai si on ne peut pas trouver des paramètres qui fonctionnent sur les 2 systèmes de serveurs. L'autre solution sera peut-être de modifier le code du client boinc...



Hors ligne [AF>Libristes>Jip] otax

  • Animateur fanatique
  • Boinc'eur devant l'éternel
  • *****
  • Messages: 5661
  •   
    • Le Libre  : Linux , Boinc et les autres  ;-)
    • E-mail
Réponse #213 le: 02 August 2007 à 21:35
 :hello:  Claude

çà a l'air effectivement d'être un problème bien embétant. Merci de nous en faire part, certains sont peut-être bloqués de façon identique...


Mais je me suis aperçu avec mes 3 cas différents d'installation Boinc sous Linux 64, Mandriva, Kubuntu et Ubuntu, que je n'ai pas pu installer Boinc chaque fois de la même manière ....  :pt1cable:

Peux-tu donc nous préciser sous quel Linux tu es et comment tu as installé Boinc (direct téléchargé de Berkeley ou par les sources Boinc compilées, mode Ustrici, voire avec un autre Boinc bricolé façon Augustine (les 3 différents cas pour moi) ?




Hors ligne claude

  • Membre d'honneur
  • Boinc'eur Respectable
  • *
  • Messages: 993
  •   
Réponse #214 le: 02 August 2007 à 23:02
 :hello:
je suis sous ubuntu 7.04 (2.6.20.15-27 generic) (version installée) avec les toutes dernières maj des packages,
j'ai d'abord installé boinc 5.4.11 avec le package de Synaptic.
désinstallé complètement.
j'ai ensuite téléchargé le dernier package 5.8.16
j'ai téléchargé ensuite les sources 5.10.17 que j'ai compilés, et installés dans les répertoires utilisés par le package, comme ça pas de reconfig.

Le problème est le même sur toutes ces versions... [:vtr webjo:10]

Pour les sources, j'ai essayé plusieurs options de compilations mais pour l'instant sans résultat intéressant.

> pour  la version des serveurs c'est tout simple, on l'a dans le log de boinc à chaque connexion au serveur-Scheduler . Mais ceux qui envoie du i686 ont l'air d'avoir la même version que certains de ceux qui ne fonctionnent pas. [:vtr webjo:10] . il semble que les version soient assez anciennes 505... mais est-ce la même numérotation que pour le client ?

Parmi mes projets, ceux qui semble jouer le jeu et renvoient du i686 pour certaines de leur applis, j'ai : RieselSieve et Seti@Home Beta (mais pas tout le temps). Il faut quand même noter qu'ils ont tout de même au moins une appli x86_64.




Hors ligne [AF>Libristes>Jip] otax

  • Animateur fanatique
  • Boinc'eur devant l'éternel
  • *****
  • Messages: 5661
  •   
    • Le Libre  : Linux , Boinc et les autres  ;-)
    • E-mail
Réponse #215 le: 02 August 2007 à 23:39
OK , je vois que tu as tout testé pour un résultat décevant ...

J'ai regardé mon client_state.xml  (que j'avais jamais regardé).
Sous Mandriva, où je ne faisais QUE les projets à applis 64 : j'avais pas la ligne alt_platform ....

Sous le K64, je l'ai (je ne l'ai pas ajoutée),directe avec Boinc 5.10.8 téléchargé de Berkeley :

Citer
x86_64-pc-linux-gnu
5
10
8
1
1
1185827357.998696
1185827231.845347
i686-pc-linux-gnu


J'ai bien le paquet Linux32 installé sous K64 (nb : n'existe pas sous mandriva64 ....  :heink:   )

mais jamais vu d'appli 32 pures arriver, en particulier CPDN  :cry:
j'ai tjs été jeté : "no appli for this plateform" .

Jusqu'à présent, je crois aussi n'avoir reçu que des "choses" 32, "empaquetées" 64  :D ....
Donc je suis dans le même cas que toi à peu près...   :whistle:
Je fouinerai plus, un peu plus tard  ;)



Hors ligne claude

  • Membre d'honneur
  • Boinc'eur Respectable
  • *
  • Messages: 993
  •   
Réponse #216 le: 02 August 2007 à 23:46
ce qui m'ennuie c'est que ça a l'air d'être au serveur de décider ou non s'il t'envoie du boulot pour la alt_platform :( , je sens que ce week-end je vais leur ruser la tête avec un client maison  :whistle:



Hors ligne Ustrici

  • Boinc'eur Junior
  • **
  • Messages: 70
Réponse #217 le: 03 August 2007 à 06:52
Citation de: claude
ce qui m'ennuie c'est que ça a l'air d'être au serveur de décider ou non s'il t'envoie du boulot pour la alt_platform :( , je sens que ce week-end je vais leur ruser la tête avec un client maison  :whistle:


C'est ce que j'ai compris aussi : le serveur identifie ton client 64bits vs 32bits, Linux vs Windows et te transmet les bonnes UTs. Sauf erreur de ma part, les projets tels que Malaria et WCG envoient des UTs en 32bits même si tu utilises un client 64bits. Ils ne tiennent pas compte du fameux tag dont tu fais mention : i686-pc-linux-gnu ou du moins ils le contournent. C'est dailleurs la raison pour laquelle je recommande d'installer les librairies 32bits sous Ubuntu pour pouvoir faire fonctionner ses deux projets.



Hors ligne claude

  • Membre d'honneur
  • Boinc'eur Respectable
  • *
  • Messages: 993
  •   
Réponse #218 le: 14 August 2007 à 00:07
 :hello:
j'ai fait quelques test sous Ubuntu 64, c'est pas terminé, mais j'ai remarqué que les paramètres de compilation du premier Post sont loin d'être optimisés semble-t-il, sur le wiki de Berkeley ils donnent les options suivantes
Citer
./configure --disable-server --enable-client CXXFLAGS="-O3 -funroll-loops -fforce-addr -ffast-math"  --disable-unicode
je suis passé d'un Dhrystone de 4400 à 5900
pour Whetstone c'est de 1800 à 2200
 :sol:



XTC_ZeuZ

  • Invité
Réponse #219 le: 14 August 2007 à 00:13
Hum interessant, perso je suis bloqué à 3200/9100 :p si je peux grapiller un peu ...

faut faire quoi avec ta citation??

edit: c'est bon j'ai trouvé  ;)

Par contre aucun changement pour moi  :sweat:



Hors ligne claude

  • Membre d'honneur
  • Boinc'eur Respectable
  • *
  • Messages: 993
  •   
Réponse #220 le: 14 August 2007 à 00:37
Je me suis peut être un peu emballé  :sweat:
même si ça influe sur les Benchmark je crois que ça n'a pas d'impact sur les applis car elles sont compilées avec leur paramètres propres, Il faudrait voir éventuellement avec les applis openSource mais je suppose que c'est déjà fait dans les distribs...

edit:tu devais déjà avoir un boinc_client bien compilé...



XTC_ZeuZ

  • Invité
Réponse #221 le: 14 August 2007 à 00:48
Oui sans doute qu'il était bien compilé déjà, pourtant j'avais suivit pas à pas l'excellent tuto en premiere page

Bha toute facon 3200/9100 ça roxx déjà pas mal :p



Hors ligne Jim PROFIT

  • Boinc'eur Respectable
  • ****
  • Messages: 896
  •   
Réponse #222 le: 16 August 2007 à 18:38
Bon après avoir lu pratiquement tout le topic, il me semble que vous utilisez tous Linux pour le x64.

Donc je souhaite savoir si des personnes l'utilisent sous W64, XP ou Vista.

Je teste en ce moment, mais j'ai du sur une machine revenir en x32 afin de pouvoir finir Climate, qui n'accepte pas le client x64.

 :hello:



Hors ligne benson

  • Boinc'eur Confirmé
  • ***
  • Messages: 255
  •   
Réponse #223 le: 21 August 2007 à 12:07
windows 64bits pas enormement de difference avec le 32bits .......linux64 parcontre ca envoye......héhé


config 1 : 3770 K (4.2 GHz) - Asus P8P67 Pro - 8 Go DDR3 (1600 Mhz) -  deux AMD Radeon HD 7950 et une AMD Radeon R9 290 - Corsair HX 1000 Watts
config 2 : 3770 K (4.2 GHz) - MSI Z77A G43 Gaming - 8 Go DDR3 (1600 MHz) - une Nvidia GeForce GTX 760 et une Nvidia GeForce GTX 970 - Corsair TX 750 watts


Hors ligne Jim PROFIT

  • Boinc'eur Respectable
  • ****
  • Messages: 896
  •   
Réponse #224 le: 21 August 2007 à 12:54
Peut-être mais je n'ai aucunement envie de refaire l'intégralité de mes PC pour passer sur Linux!

Chez moi tout est géré en environnement Windows et pas de soucis, donc pourquoi changer. Finis le temps ou je pouvais perdre un week-end à configurer ou chercher un problème sur un PC!! Et Linux m'a fait perdre un paquet d'heures.....

Je trouve quand même le Vista 64 plus stable et performant, pas énormément mais déjà un petit plus.

M'enfin ne partons pas sur un débat stérile, Linux c'est bien, je l'ai sur la PS3, mais il faut avoir du temps devant soi.

 :hello: